Информатика, вопрос задал tartimilkaklips , 2 года назад

PYTHON(python) (Для 7-8 класса)
Решение через for I in range
«C»: Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [100,500] и выводит его на экран. После этого на экран выводятся суммы цифр всех чисел, записанных в массив.
Пример:
Массив: 162 425 340 128 278 195 326 414 312 177
Суммы цифр: 9 11 7 11 17 15 11 9 6 15

Ответы на вопрос

Ответил ppgem374
1

import random

A = [0] * 10

for i in range(10):

   A[i] = random.randint(100, 500)

   

print("Массив:", A)

for i in range(10):

   s = 0

   x = A[i]

   while x > 0:

       s += x % 10

       x //= 10

   print("Сумма цифр числа", A[i], "равна", s)


tartimilkaklips: Можно пж без Randit и append
tartimilkaklips: Чтоб прям очень просто выглядело,а то учитель запалит
ppgem374: Randint - это элементарный метод, легче чем им сложно сделать. Append убрал.
tartimilkaklips: Спасиб
tartimilkaklips: Блин,у меня не работает
Новые вопросы