Информатика, вопрос задал annrnb , 7 лет назад

Python, пожалуйста!)
Уровень E. Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи две одинаковые цифры, стоящие рядом.

Ответы на вопрос

Ответил KnowsUser1
0

Ответ:

some_num = input()  

splited_num = list(some_num)

isSameNumNear = False

for index in range(len(splited_num)-1):

   if splited_num[index] == splited_num[index+1]: isSameNumNear = True  

print('2 цифры идут подряд' if isSameNumNear else 'Все цифры разные')

Приложения:
Ответил misterioe
0
это же то же самое, что и мой код (работает так же)
Ответил misterioe
0

Ответ:

Если я правильно понял:

Объяснение:

n=input()

for i in range(0, len(n)-1):

  if n[i]==n[i+1]:

     print("YES")

     exit()

P.S. Отпиши если не работает

Приложения:
Новые вопросы