Информатика, вопрос задал arinahachuknigu , 7 лет назад

Python, пожалуста
Разделим квадратную матрицу диагональю, соединяющую правый верхний элемент с левым нижним. Такую диагональ обычно называют "побочной":

Входные данные
На вход программе сначала подается значение n ≤ 20 – размер квадратной матрицы. В следующих n строках входных данных расположены сами элементы матрицы – натуральные числа, меньшие 100.

Выходные данные
Распечатайте в виде треугольной таблицы элементы матрицы, стоящие выше побочной диагонали, выравнивая значения по столбцам так, как показано в примере. О способе выравнивания вывода в Python можно прочитать в условии задачи Треугольник Паскаля - 2.

Примеры
входные данные
4
1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 16
выходные данные
1 2 3 4
5 6 7
9 10
13
https://informatics.mccme.ru/moodle/mod/statements/view3.php?chapterid=1589#1

Ответы на вопрос

Ответил budzsergiy777p0i27m
0

from random import randint

def matrix(n):

   matrix_list = [[randint(0,100) for x in range(n)] for i in range(n)]

   for w in matrix_list:

       print(w)

   print()

   q = len(matrix_list)

   while q > 0:

       for z in matrix_list:

           print(z[:q])

           q -= 1

matrix(10)

Новые вопросы