Информатика, вопрос задал snakesap , 8 лет назад

PYTHON паммгите
По данным числам n и m заполните двумерный массив размером n×m числами от 1 до nm “змейкой”, как показано в примере.

Входные данные
Вводятся два числа n и m

Выходные данные
Выведите полученный массив, отводя на вывод каждого элемента ровно 4 символа.

Примеры
входные данные
3 5

выходные данные
1 2 3 4 5
10 9 8 7 6
11 12 13 14 15

Ответы на вопрос

Ответил srzontmp
0
n=int(input('n = '));
m=int(input('m = '));
for i in range(1,n+1):
    s='';
    for j in range(1,m+1):
        if (i%2==1): s=s+str((i-1)*m+j).rjust(4);
        else: s=s+str((i-1)*m+m-j+1).rjust(4);
    print(s);
   
n = 5
m = 5
    1    2   3     4    5
  10    9   8     7    6
  11  12  13  14  15
  20  19  18  17  16
  21  22  23  24  25


n = 5
m = 8
   1     2     3    4    5    6     7   8
  16  15  14  13  12  11  10   9
  17  18  19  20  21  22  23  24
  32  31  30  29  28  27  26  25
  33  34  35  36  37  38  39  40

Новые вопросы