Информатика, вопрос задал illiacherkas626 , 1 год назад

python Назовем пароль крипто стойким, если выполнены 5 критериев 1. Пароль содержит строчные латинские буквы 2. Пароль содержит заглавные латинские буквы 3. Пароль содержит цифры Символы: 1 " # $ % &' ( ) * + 5. Длина пароля не менее 8 символов Требуется по данному паролю определить, сколько критериев крипто стойкости выполнено. 4. Входные данные Вводится одна строка, состоящая только из латинских букв, цифр и символов из условия. Количество символов в строке не превышает 100. Выходные данные Выведите количество критериев крипто стойкости, которым удовлетворяет пароль.​

Ответы на вопрос

Ответил slonce70
0

password = input()

criteria = 0

if any(char.islower() for char in password):

   criteria += 1

if any(char.isupper() for char in password):

   criteria += 1

if any(char.isdigit() for char in password):

   criteria += 1

if any(char in '!"#$%&\'()*+' for char in password):

   criteria += 1

if len(password) >= 8:

   criteria += 1

print(criteria)

Приложения:
Новые вопросы