Другие предметы, вопрос задал 5OTLYCHNIK5 , 1 год назад

Python.
Напишите программу поиска заданной информации из нескольких файлов.


Формат ввода:

Сначала вводится поисковый запрос.

Затем вводятся имена файлов, среди которых следует произвести поиск.


Формат вывода:

Выведите все имена файлов, в которых есть поисковая строка без учета регистра и

повторяющихся пробельных символов.

Если ни в одном файле информация не была найдена, выведите "404. Not Found".

Ответы на вопрос

Ответил revivalvimeworld
1

Ответ:

Объяснение:

Пример кода на Python для решения задачи:

import re

# Запрос пользователя

query = input("Введите поисковый запрос: ")

# Список файлов для поиска

files = input("Введите имена файлов через пробел: ").split()

# Регулярное выражение для поиска строки без учета регистра и повторяющихся пробельных символов

regex = re.compile(r"\b" + re.escape(query) + r"\b", re.IGNORECASE)

# Список файлов, в которых найдена информация

found_files = []

# Поиск в каждом файле

for file in files:

   with open(file, "r") as f:

       content = f.read()

       if regex.search(content):

           found_files.append(file)

# Вывод результатов

if found_files:

   print("Найдено в файлах:", ", ".join(found_files))

else:

   print("404. Not Found")

Программа запрашивает у пользователя поисковый запрос и список файлов для поиска, используя функцию input(). Затем создается регулярное выражение для поиска строки без учета регистра и повторяющихся пробельных символов, используя модуль re.

Далее программа проходится по каждому файлу в списке и ищет в нем строку с помощью метода search() объекта регулярного выражения. Если строка найдена, то имя файла добавляется в список found_files.

Наконец, программа выводит список файлов, в которых найдена информация, или сообщение "404. Not Found", если информация не была найдена.

Новые вопросы