Информатика, вопрос задал lilithvatoresas , 6 лет назад

python
Напишите программу, которая выполняет реверс массива: меняет местами первый и последний элементы, второй и предпоследний и т.д.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Примеры
входные данные
6
1 2 3 4 5 6
выходные данные
6 5 4 3 2 1

Ответы на вопрос

Ответил лекция
1

легко, но скорее всего не то, что нужно:

n = int(input())

List = list(map(int, input().split()))

List = List[::-1]

print(List)

то, что нужно:

n = int(input())

List = list(map(int, input().split()))

for i in range(n//2 + 1):

   k = List[i]

   List[i] = List[n-i-1]

   List[n-i-1] = k

print(List)


lilithvatoresas: ВЫ МЕНЯ СПАСЛИ СПАСИБО ОГРОМНОЕ
лекция: вспомнил, вывод должен выглядеть как print(*List)
лекция: пожалуйста
Новые вопросы