Информатика, вопрос задал bandagewrap , 6 лет назад

(Python) Напишите программу которая вычислит сумму всех четных чисел от 1 до 90 включительно, используя оператор for

Дескриптор:
Описывает входные данные
Записывает условие
Вычисляет сумму
Наращивает параметр
Выводит результат


mathgenius: В 1 строчку: print(sum(map(lambda x: x*((x+1)%2), list(range(1,91)))))
mathgenius: Либо так: s = 0 for i in range(0,91,2): s +=i (выход из цикла) print(s)

Ответы на вопрос

Ответил daniyarkanu
1

Ответ:

summ = 0

for i in range(1, 91):

   if i % 2:

       summ += i

print(summ)

Новые вопросы