Информатика, вопрос задал ILW , 1 год назад

PYTHON!!!
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Входные данные
В первой строке вводятся через пробел координаты первой точки (сначала x -координата, потом y -координата), во второй строке в том же порядке – координаты второй точки. Все координаты – вещественные числа.

Выходные данные
Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части

Ответы на вопрос

Ответил Olga8128
2

x1, y1 = [float(i) for i in input ().split()]

x2, y2 = [float(i) for i in input ().split()]

d = ((x2 - x1) ** 2 + (y2 - y1) ** 2) ** 0.5

print(round(d, 3))

В первой и второй строчках осуществлен ввод координат обеих точек: (x_1;y_1) и (x_2;y_2). Дальше по формуле d=\sqrt{(x_2-x_1)^2+(y_2-y_1)^2}, которая по сути является теоремой Пифагора, находим расстояние между точками (напоминаю, что "**" - это степень, а корень - это "**0.5"). И округляем до третьего знака с помощью round.

Вместо четвертой строки с функцией round можно попробовать написать следующее:

a = (str(d) + '000').split('.')

if int(a[1][3]) < 5:

   print(a[0] + '.' + a[1][0] + a[1][1] + a[1][2])

else:

   print(a[0] + '.' + a[1][0] + a[1][1] + str(int(a[1][2] + 1)))

Новые вопросы