Информатика, вопрос задал dbog3690 , 1 год назад

PYTHON
Напишите программу, которая находит наименьшее (min(числа через зит)) и набольшее(mах(числа через зит)) из пяти чисел. Программа должна вывести наименьшее и наибольшее число с поясняющей надписью.

Ответы на вопрос

Ответил MagicSticks
0

Ответ:

nums = input("Введите пять чисел через пробел: ")

nums_list = nums.split()

# Преобразуем строки в списке в числа

for i in range(len(nums_list)):

   nums_list[i] = int(nums_list[i])

# Находим минимальное и максимальное число в списке

min_num = min(nums_list)

max_num = max(nums_list)

# Выводим результат

print("Наименьшее число: ", min_num)

print("Наибольшее число: ", max_num)

Объяснение:

После запуска программы пользователь должен будет ввести пять чисел через пробел. После этого программа найдет наименьшее и наибольшее число в списке и выведет результаты на экран с поясняющей надписью.

Пример вывода программы при вводе чисел "5 10 3 7 1":

Введите пять чисел через пробел: 5 10 3 7 1

Наименьшее число: 1

Наибольшее число: 10

Новые вопросы