Информатика, вопрос задал Наглый2 , 2 года назад

Python: напишите программу, которая ищет сумму четных делителей заданного натурального числа.

Ответы на вопрос

Ответил FANTSCR1N
1

number = int(input('Введите число: '))

s = 0

for divisor in range(1, number + 1):

   if (number % divisor == 0) and (divisor % 2 == 0):

       s += divisor

print('Сумма четных делителей:', s)

Новые вопросы