Информатика, вопрос задал tyukova123a7 , 1 год назад

Python
Напишите программу, которая будет удалять все комментарии из исходного файла с кодом на языке Python.

Пройдите по всем строкам в файле для поиска символа '#'. Обнаружив его, программа должна удалить все содержимое, начиная с этого символа и до конца строки. Гарантируется, что знак решетки не встречается в середине строки (то есть после какого-то текста, отступы до символа присутствовать могут). Сами строки удалять не нужно, количество строк в выводе должно совпадать с количеством строк в файле.

Выведите новое содержимое на экран. Имя файла подается на вход и заранее не известно. Если указанного файла не существует, необходимо вывести соответствующее сообщение об ошибке FileNotFoundError: "Файл не найден". Если происходит другая ошибка, вывести сообщение об ошибке Exception: "Неизвестная ошибка".

Ответы на вопрос

Ответил archie242
0

Відповідь:

import os

filename = input("Введите имя файла: ")

# проверяем, существует ли файл

if not os.path.exists(filename):

   print("Файл не найден")

else:

   try:

       with open(filename, "r") as f:

           for line in f:

               # ищем символ '#' в строке и удаляем все, что после него

               index = line.find("#")

               if index != -1:

                   line = line[:index]

               print(line.rstrip()) # выводим обработанную строку без лишних пробелов

   except Exception:

       print("Неизвестная ошибка")

Новые вопросы