Информатика, вопрос задал chesskrashtarsta , 1 год назад

python напишите программу которая будет определять среднее арифметическое значение введенных чисел. Числа вводить до тех пор пока не введут 0

Ответы на вопрос

Ответил annazaezc
0

Ответ:

Звучит просто! Вот код на Python:

```python

numbers = []

while True:

   num = int(input("Введите число: "))

   if num == 0:

       break

   numbers.append(num)

avg = sum(numbers) / len(numbers)

print("Среднее арифметическое: ", avg)

```

В этой программе мы создаем пустой список `numbers`, затем запускаем бесконечный цикл `while`. Внутри цикла мы запрашиваем у пользователя ввод числа и проверяем, равно ли оно нулю. Если да, то мы выходим из цикла с помощью оператора `break`. Если нет, то мы добавляем число в список `numbers`.

После того, как пользователь ввел все числа, мы находим среднее арифметическое значение с помощью функции `sum()` и оператора деления `/`. Затем мы выводим результат на экран с помощью функции `print()`.

Объяснение:

Новые вопросы