Информатика, вопрос задал vadim8556 , 7 лет назад

Python
Мне нужна помощь , мне нужно написать программу которая будет задавать вопросы та выдавать ответы, если ответ правильный то говорит что «правильно »а если нет то «ответ неверный »
примерно 5 вопросов , и задача не должна быть очень сильно завалила всякими циклами ​

Ответы на вопрос

Ответил arseney0cs
0

bank_ques = {}

#Создание вопросов:

# bank_ques["сам вопрос"'] = "Ответ на него", вопрос и ответ в виде строки, даже если это число

bank_ques["2*2"] = "4"

bank_ques["3*3"] = "9"

bank_ques["4*4"] = "16"

bank_ques["5*5"] = "25"

bank_ques["6*6"] = "36"

#Вопросов может быть неограниченное количество

# Также генерировать вопросы можно как в самом коде, так и сделать в цикле, но тут уже как хотите

for question in bank_ques:

   print(question)

   answer = input("Ответ: ")

   if answer == bank_ques[question]:

       print("правильно")

   else:

       print("ответ неверный")

Ответил vadim8556
0
спасибо за помощь , я понял как это зделать
Новые вопросы