Информатика, вопрос задал artempula61 , 2 года назад

PYTHON!!!!!!!!!!
Карапуз Геннадий хвастается перед другими карапузами тем, что умеет складывать числа. К сожалению, ещё не все числа подвластны Геннадию, он умеет складывать только положительные однозначные числа (от 0 до 9).

Друзья называют Геннадию N различных чисел, а Геннадий складывает только те, что может. Какая сумма получится у карапуза в качестве ответа?
Формат входных данных

В первой строке вводится единственное натуральное число N, не превосходящее 1000. Далее вводятся N целых чисел, которые больше -10000 и меньше 10000.
Формат выходных данных

Одно число - ответ.
входные данные выходные данные

5

2

10

4

-6

-10



6

4

-3

11

-19

15



0

Ответы на вопрос

Ответил pinguinbird
2

Ответ:

s = 0

n = int(input('Введите количество чисел: '))

for i in range(n):

 while True:

   v = int(input(f'Введите {i+1}-е число: '))

   if -10000 < v < 10000: break

   print('Вводите число больше -10000 и меньше 10000')

 if 0 <= v <= 9: s+=v

print('Сумма однозначных положительных чисел равна', s)

Новые вопросы