Информатика, вопрос задал lilithvatoresas , 6 лет назад

python
Где равные X?
Напишите программу, которая выводит номера элементов массива, равных заданному значению X .

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке номера элементов массива, равных X , разделив их пробелами. Предполагается, что нумерация начинается с единицы. Если таких элементов нет, нужно вывести число -1.

Примеры
входные данные
5
1 2 1 3 5
1
выходные данные
1 3

Ответы на вопрос

Ответил лекция
1

n = int(input())

List = list(map(int, input().split()))

X = int(input())

flag = 0

for i in range(n):

   if List[i] == X:

       print(i + 1, end = ' ')

       flag += 1

if flag == 0:

   print(-1)

Новые вопросы