Информатика, вопрос задал tyukova123a7 , 1 год назад

Python
Фёдор и Соня для общения друг с другом придумали собственный шифр, в котором буквы шифруются последовательностями цифр. Между закодированными буквами ставится ровно один пробел. Например, слово ''котик'' превратится в ''25 33 41 23 25''. Обратите внимание, что строчные и заглавные буквы кодируются одинаково.

Вот кодовая таблица:

'а': '11', 'б': '12', 'в': '13', 'г': '14', 'д': '15', 'е': '16', 'ж': '21', 'з': '22', 'и': '23', 'й': '24', 'к': '25', 'л': '26', 'м': '31', 'н': '32', 'о': '33', 'п': '34', 'р': '35', 'с': '36', 'т': '41', 'у': '42', 'ф': '43', 'х': '44', 'ц': '45', 'ч': '46', 'ш': '51', 'щ': '52', 'ъ': '53', 'ы': '54', 'ь': '55', 'э': '56', 'ю': '61', 'я': '62'

Формат ввода
Весь текст записан в единственной строке. Текст состоит из русских букв и пробелов, других символов в тексте нет. В тексте не может быть двух или более пробелов подряд.

Формат вывода
Выведите каждое слово исходного текста, закодированное шифром, на отдельной строке.

Количество строк в ответе должно совпадать с количеством слов в исходном тексте.

Пример
Ввод
котик
Вывод
25 33 41 23 25

Ответы на вопрос

Ответил skymaster4890
0

Ответ:

+

Объяснение:
Решение:

code_table = {'а': '11', 'б': '12', 'в': '13', 'г': '14', 'д': '15', 'е': '16', 'ж': '21', 'з': '22', 'и': '23', 'й': '24', 'к': '25', 'л': '26', 'м': '31', 'н': '32', 'о': '33', 'п': '34', 'р': '35', 'с': '36', 'т': '41', 'у': '42', 'ф': '43', 'х': '44', 'ц': '45', 'ч': '46', 'ш': '51', 'щ': '52', 'ъ': '53', 'ы': '54', 'ь': '55', 'э': '56', 'ю': '61', 'я': '62'}

# Считываем строку из ввода

message = input()

# Разбиваем строку на слова

words = message.split()

# Шифруем каждое слово и выводим его

for word in words:

   code = ''

   for char in word:

       # Если буква есть в таблице, добавляем ее код в шифр

       if char in code_table:

           code += code_table[char]

   print(code)

Пример использования:

Ввод:
Привет, как дела?

Вывод:
355332  3316  251435?


tyukova123a7: Простите, а как вывести ответ как в примере, просто числа должы быть раздельно, т.е не 355332 а 35 53 32
Новые вопросы