Информатика, вопрос задал artempula61 , 6 лет назад

Python!!
Даны две строки - заклинания, которые нужно выучить к завтрашнему тесту.
Найдите, какое из них самое короткое и выведите его на экран, написанным только строчными буквами.

Гарантируется, что заклинания разной длины.

Формат входных данных

Две строки - заклинания. В исходных строках могут быть буквы любого регистра.
Формат выходных данных

Самое короткое из заклинаний. Сделать все буквы строчными.
входные данные выходные данные

ОстОЛБЕней

ЗаМЁрзнь



замёрзнь

ВЖУХ

АлоХамора



вжух


Рулез: Тут тоже функцию написать? Входные данные с клавиатуры вводятся?
artempula61: Функцию да и данные то нужны

Ответы на вопрос

Ответил Рулез
1

Ответ:

def magic(a, b):

   if len(a) < len(b):

       return a.lower()

   return b.lower()

print(magic('ОстОЛБЕней', 'ЗаМЁрзнь'))

Объяснение:

Новые вопросы