Информатика, вопрос задал oooooooooooooooo10 , 2 года назад

Python 3
Базовые алгоритмы теории чисел
Простое число
По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число.

Входные данные

Дано натуральное число K.

Выходные данные

Выведите K-е простое число.

Примеры
Ввод
Вывод
3
5
1
2
Ограничения
Время выполнения: 3 секунды

Ответы на вопрос

Ответил damskiyugodnik43
1

import math

k = int(input())

cnt = 0

cur = 2

while cnt < k :

   p = 1

   for i in range(2, int(math.sqrt(cur)) + 1):

       if(cur % i == 0):

           p = 0

   if(p == 1):

       cnt += 1

   if(cnt == k):

       print(cur)

   cur += 1

Новые вопросы