Информатика, вопрос задал KELMY , 6 лет назад

PYTHON
1)Напишите программу, которая заполняет матрицу из N строк и M столбцов нулями и единицами в шахматном порядке.
2)Напишите программу, которая заполняет матрицу из N строк и N столбцов нулями и единицами так, что все элементы выше побочной диагонали равны нулю, а остальные – единице.

Ответы на вопрос

Ответил kginiatullin076
0

1)

ar = []

n = int(input())

m = int(input())

for i in range(m):

   ar1 = []

   for j in range(n):

       if i % 2 == j % 2:

           ar1.append(1) #единицу и ноль можно поменять местами

       else:

           ar1.append(0)

   ar.append(ar1)

2)

ar = []

n = int(input())

for i in range(n):

   ar1 = []

   for j in range(n):

       if j > i:

           ar1.append(0)

       else:

           ar1.append(1)

   ar.append(ar1)

#по заданию если что вывода быть не должно, но вот он:

for g in ar:

   print(*g)

#Примечание: вывод работает для обоих случаев!

Новые вопросы