Информатика, вопрос задал Cukatik322 , 2 года назад

python
1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами в диапазоне [0,20], выводит его на экран, а затем меняет местами пары соседних элементов, кроме первого и последнего (2-й с 3-м, 4-й с 5-м и т.д.).
Пример:
Массив: 5 16 2 13 3 14 18 17
Реверс: 5 2 16 3 13 18 14 17

Ответы на вопрос

Ответил vimmortal2
0

Программа:
Python:

from random import randint

N = 8

arr = [randint(0, 20) for i in range(N)]

for i in arr: print(i, end=' ')

for i in range(N - 1):

   if i % 2 != 0:

       arr[i], arr[i + 1] = arr[i + 1], arr[i]

print()

for i in arr: print(i, end=' ')

Объяснение:

В начале импортируем метод randint из библиотеки random, далее - переменной N присваиваем значение 8 (как по условию). Заполняем массив N элементами в диапазоне от 0 до 20. С помощью цикла и метода print() выводим элементы через пробел.

С помощью цикла переменная i принимает значения от 0 до N - 1. Если сейчас нечётное число (а это 1, 3, 5 (без 7)), мы меняем местами текущий элемент и следующий с помощью множественного присваивания.

В конце - с помощью пустого метода print() переходим на следующую строку и с помощью цикла и метода print() выводим элементы через пробел.

Результат:

19 16 13 16 10 10 19 17

19 13 16 10 16 19 10 17

7 10 15 2 19 7 4 6

7 15 10 19 2 4 7 6

Новые вопросы