ПРЯМ СРОЧНО
Составьте программу которая определяет количество в массиве четных чисел используя подпрограмму проверки четности массива
Ответы на вопрос
Ответил supersuperkirip54irs
0
var a:array of integer;
N,i,k:integer;
function f(a:integer):Boolean;
begin
if (a mod 2=0) then f:=True else
f:=False;
end;
BEGIN
k:=0;
writeln('Введите количество элементов массива');
readln(N);
SetLength(A,N);
writeln('Введите массив');
for i:=0 to N-1 do begin
read(a[i]);
if (f(a[i])=True) then k:=k+1;
end;
writeln('Количество чётных элементов массива = ',k);
end.
Вводите с клавиатуры кол-во элементов массива, а затем сам массив.
Ответил csharp
0
Во-первых: в условии сказано проверять массив на чётность, а не каждый элемент. Во-вторых - представьте, что случится с памятью, когда Вы объявите массив на 999999 элементов, а программа все 999999 итераций (раз) будет вызывать функцию.
Ответил supersuperkirip54irs
0
Что тогда является проверкой массива на чётность?
Ответил csharp
0
Это значит передать в функцию массив и проверять его элементы.
> используя подпрограмму проверки четности массива
> используя подпрограмму проверки четности массива
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Математика,
9 лет назад