ПРШУ НА ПАСКАЛЕЕЕЕЕЕЕЕЕЕ3. Напишите программу, которая заполняет массив из 20 элементов случайными числами на
отрезке [0; 200) и считает количество элементов, которые не делятся на 10.
Ответы на вопрос
Відповідь:
program RandomArray;
const
N = 20; // Количество элементов в массиве
Range = 200; // Верхняя граница для случайных чисел
var
arr: array[1..N] of Integer;
countNotDivisibleBy10: Integer;
i: Integer;
begin
// Инициализация генератора случайных чисел
Randomize;
// Заполнение массива случайными числами
for i := 1 to N do
arr[i] := Random(Range);
// Вывод массива
writeln('Массив случайных чисел:');
for i := 1 to N do
write(arr[i], ' ');
// Подсчет количества элементов, не делящихся на 10
countNotDivisibleBy10 := 0;
for i := 1 to N do
if arr[i] mod 10 <> 0 then
Inc(countNotDivisibleBy10);
// Вывод результата
writeln;
writeln('Количество элементов, не делящихся на 10: ', countNotDivisibleBy10);
readln;
end.