Проверьте, пожалуйста, программу. Вот задание: составьте программу, выводящую на экран все двухзначные числа, у которых первая цифра в два раза больше второй. Только честно, пожалуйста. Это очень важно)
program abc;
var x, k, i: integer;
begin
i:=0;
for k:=0 to 9 do
begin
for x:=1 to 9 do
if k mod 2=x then i:=i+1;
end;
writeln(i)
end.
Ответы на вопрос
Ответил sasha31072002
0
Вот более правильное решение
var x, k, i: integer;
begin i := 0; for k := 1 to 9 do begin for x := 1 to 9 do if k / 2 = x then writeln(k, x); end;end.
var x, k, i: integer;
begin i := 0; for k := 1 to 9 do begin for x := 1 to 9 do if k / 2 = x then writeln(k, x); end;end.
Ответил sasha31072002
0
криво написано, за это извини
Новые вопросы
Литература,
2 года назад
История,
2 года назад
Математика,
8 лет назад
Литература,
8 лет назад
Химия,
9 лет назад