Проверочная работа.
1)Задача
Написать программу, подсчитывающую количество четных и нечетных цифр в числе.
2)Задача
Вводится число. Преобразовать его в другое число, цифры которого будут следовать в обратном порядке по сравнению с введенным числом.
3)Задача
Вывести на экран ряд чисел Фибоначчи, состоящий из n элементов.
Омскаяптица:
А язык какой?
Ответы на вопрос
Ответил Омскаяптица
1
Ответ:
1)
var
a: integer;
even,odd: byte;
begin
readln(a);
even := 0;
odd := 0;
while a > 0 do begin
if (a mod 2) = 0 then
even := even + 1
else
odd := odd + 1;
a := a div 10;
end;
writeln('even: ', even);
writeln('odd: ', odd);
end.
2)
var
n, m: longint;
a: byte;
begin
readln(n);
m := 0;
while n>0 do begin
a := n mod 10;
n := n div 10;
m := m*10 + a;
end;
writeln(m);
readln;
end.
3)
var
a,b,c,i,n: integer;
begin
write('n = ');
readln(n);
a := 0;
write(a,' ');
b := 1;
write(b,' ');
for i:=3 to n do begin
write(a+b,' ');
c := b;
b := a + b;
a := c
end;
readln
end.
Объяснение:
Приложения:



Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Алгебра,
8 лет назад