ПРОШУ СРОЧНО НА ПАСКАЛЕ
5. Напишите программу, которая заполняет массив из 20 элементов случайными числами на
4. Напишите программу, которая заполняет массив из 20 элементов случайными числами на
3. Напишите программу, которая заполняет массив из 20 элементов случайными числами на
отрезке (10; 100] и считает число пар соседних элементов, сумма которых делится на 3.
2. Напишите программу, которая заполняет массив из 10 элементов случайными числами на
отрезке [0; 200] и считает число двузначных чисел в массиве.
1. Напишите программу, которая заполняет массив из 10 элементов случайными числами на
отрезке [0; 200] и считает сумму элементов, которые делятся на 10.
отрезке [2; 10] и считает отдельно количество чётных и нечётных элементов.
отрезке [-2; 2] и считает произведение положительных элементов массива.

Ответы на вопрос
Ответ:
1
program SumDivisibleByTen;
const
arraySize = 10;
var
numbers: array[1..arraySize] of integer;
sumDivisibleByTen: integer;
i: integer;
begin
Randomize;
sumDivisibleByTen := 0;
for i := 1 to arraySize do
begin
numbers[i] := Random(201); // Генерация чисел в диапазоне [0; 200]
if numbers[i] mod 10 = 0 then
sumDivisibleByTen := sumDivisibleByTen + numbers[i];
end;
writeln('Сумма элементов, которые делятся на 10: ', sumDivisibleByTen);
readln;
end.
2program CountTwoDigitNumbers;
const
arraySize = 10;
var
numbers: array[1..arraySize] of integer;
countTwoDigitNumbers: integer;
i: integer;
begin
Randomize;
countTwoDigitNumbers := 0;
for i := 1 to arraySize do
begin
numbers[i] := Random(201); // Генерация чисел в диапазоне [0; 200]
if (numbers[i] >= 10) and (numbers[i] <= 99) then
Inc(countTwoDigitNumbers);
end;
writeln('Количество двузначных чисел в массиве: ', countTwoDigitNumbers);
readln;
end.
3program CountPairsSumDivisibleByThree;
const
arraySize = 20;
var
numbers: array[1..arraySize] of integer;
countPairsSumDivisibleByThree: integer;
i: integer;
begin
Randomize;
countPairsSumDivisibleByThree := 0;
for i := 1 to arraySize do
begin
numbers[i] := Random(91) + 10; // Генерация чисел в диапазоне (10; 100]
end;
for i := 1 to arraySize - 1 do
begin
if (numbers[i] + numbers[i + 1]) mod 3 = 0 then
Inc(countPairsSumDivisibleByThree);
end;
writeln('Число пар соседних элементов, сумма которых делится на 3: ', countPairsSumDivisibleByThree);
readln;
end.
4program CountEvenOddNumbers;
const
arraySize = 10;
lowerBound = 2;
upperBound = 10;
var
numbers: array[1..arraySize] of integer;
countEven, countOdd: integer;
i: integer;
begin
Randomize;
countEven := 0;
countOdd := 0;
for i := 1 to arraySize do
begin
numbers[i] := Random(upperBound - lowerBound + 1) + lowerBound; // Генерация чисел в диапазоне [2; 10]
if numbers[i] mod 2 = 0 then
Inc(countEven)
else
Inc(countOdd);
end;
writeln('Количество чётных элементов: ', countEven);
writeln('Количество нечётных элементов: ', countOdd);
readln;
end.
5program ProductOfPositiveNumbers;
const
arraySize = 10;
lowerBound = -2;
upperBound = 2;
var
numbers: array[1..arraySize] of integer;
productPositive: integer;
i: integer;
begin
Randomize;
productPositive := 1;
for i := 1 to arraySize do
begin
numbers[i] := Random(upperBound - lowerBound + 1) + lowerBound; // Генерация чисел в диапазоне [-2; 2]
if numbers[i] > 0 then
productPositive := productPositive * numbers[i];
end;
writeln('Произведение положительных элементов массива: ', productPositive);
readln;
end.
Объяснение:
Эти программы выполняют каждую из задач, на языке программирования Pascal.