Информатика, вопрос задал alyagrossman , 8 лет назад

Прошу, ребят.. В ПАСКАЛЕЕЕЕ
Составьте программу, находящую из трех чисел X, Y, Z наибольшее.
Сначала выбрать наибольшее число из двух – X, Y и присвоить полученное значение переменной С, затем выбрать наибольшее из чисел С и Z и присвоить полученное значение переменной C

Ответы на вопрос

Ответил petyaGavrikov
0
var x,y,z,c: integer;
begin
write('x, y, z:');
readln(x,y,z);
if x>y then c:=x else c:=y;
if z>c then c:=z;
writeln('c = ',c);
end.

Пример:
x, y, z:
5 8 4
c = 8
Новые вопросы