Прошу помощи по информатике. Требуется написать программу на паскале по этой формуле min (ab, ac, bc) (это нахождение наименьшего значения, как я понимаю). Прошу помочь (я гуманитарий).
Ответы на вопрос
Ответил wwwert1239
0
var a,b,c:integer;
begin
readln(a);readln(b);readln(c);
if (a*b < a*c)and (a*b < b*c)then
writeln(a*b)else
if (a*c < a*b)and (a*c < b*c)then
writeln(a*c)else writeln(b*c);
end.
Ответил wwwert1239
0
так максимума или минимума?
Ответил sokirkin03
0
минимума
Ответил wwwert1239
0
ок
Ответил wwwert1239
0
var
a, b, c: real;
begin
readln(a);readln(b);readln(c);
if (a * b < a * c) and (a * b < b * c) then
begin
writeln(a, '*', b);
if (a * b <= 2) and (a * b >= 0.5) then writeln('YES') else writeln('NO'); end
else
if (a * c < a * b) and (a * c < b * c) then
begin
writeln(a, '*', c);
if (a * c <= 2) and (a * c >= 0.5) then
writeln('YES') else writeln('NO'); end
else begin
writeln(b, '*', c);
if (b * c <= 2) and (b * c >= 0.5) then
writeln('YES') else writeln('NO'); end;
end.
a, b, c: real;
begin
readln(a);readln(b);readln(c);
if (a * b < a * c) and (a * b < b * c) then
begin
writeln(a, '*', b);
if (a * b <= 2) and (a * b >= 0.5) then writeln('YES') else writeln('NO'); end
else
if (a * c < a * b) and (a * c < b * c) then
begin
writeln(a, '*', c);
if (a * c <= 2) and (a * c >= 0.5) then
writeln('YES') else writeln('NO'); end
else begin
writeln(b, '*', c);
if (b * c <= 2) and (b * c >= 0.5) then
writeln('YES') else writeln('NO'); end;
end.
Ответил wwwert1239
0
так?
Новые вопросы