Информатика, вопрос задал GelyaKazarik , 8 лет назад

ПРОШУ ПОМОГИТЕ, ОЧЕНЬ НУЖНО!!
ИНФОРМАТИКА 10 КЛАСС, PASCAL.
Дана строка, содержащая два слова, разделенные дефисом. написать программу, добавляющую пробел до и после дефиса

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  var p:=Pos('-',s);
 if p>0 then begin s:=s.Replace('-',' - '); Writeln(s) end
  else Writeln('Дефис не найден')
end.

Пример
черно-белый
черно - белый

Новые вопросы