Прошу помогите на Зачёте: Дано массив целых чисел A[N]. Проверьте, есть ли в нем отрицательные элементы. Если есть, найдите наибольшее i, при котором A[i]<0, иначе выведите сообщение.
Ответы на вопрос
Ответил Adequate
0
Программа находит наибольшее отрицательное число из n чисел, так как рандом состоит из положительных и отр. чисел, не стал писать else. Код кривой, но рабочий :)
program asd;
USES crt;
var a:array[1..100]of integer;
i,n,max:integer;
BEGIN
clrscr;
Writeln('Vvedite kol-vo chisel: ');
Readln(n);
for i:=1 to n do
begin
A[i]:=random(20)-10;
Write(' ',A[i]);
end;
max:=A[1];
for i:=2 to n do
begin
if (A[i]<0) then
begin
if (A[i]<max) then max:=A[i]
end;
end;
Writeln;
Writeln('Maksimalnoe chislo pri A[i]<0 = ',max);
END.
program asd;
USES crt;
var a:array[1..100]of integer;
i,n,max:integer;
BEGIN
clrscr;
Writeln('Vvedite kol-vo chisel: ');
Readln(n);
for i:=1 to n do
begin
A[i]:=random(20)-10;
Write(' ',A[i]);
end;
max:=A[1];
for i:=2 to n do
begin
if (A[i]<0) then
begin
if (A[i]<max) then max:=A[i]
end;
end;
Writeln;
Writeln('Maksimalnoe chislo pri A[i]<0 = ',max);
END.
Ответил Adequate
0
Напишите мне, каким образом должен отображаться массив ?
Иванов Иван Иванович это процедурой
Данные об студенте надо водить ?
И выводить относительно процедуры :
Студент:МПЕК; ФИО:Иванов Иван Иванович; СР.Б.С:n;
Я правильно понял ?
Иванов Иван Иванович это процедурой
Данные об студенте надо водить ?
И выводить относительно процедуры :
Студент:МПЕК; ФИО:Иванов Иван Иванович; СР.Б.С:n;
Я правильно понял ?
Ответил Adequate
0
Сделал, все работает,но задача заставила подумать, где ты учишься ?
Ответил Аноним
0
МИФИ, 1 ый курс
Ответил Аноним
0
а где программа? :)
Новые вопросы
История,
2 года назад
Литература,
2 года назад
Химия,
10 лет назад
Химия,
10 лет назад
Физика,
10 лет назад