Информатика, вопрос задал samakovajat879 , 7 лет назад

прошу помогите как написать программу питон которая находит наименьшее число которое больше другого ​


artum3d: Можешь сказать свой вопрос поконкретней? Я не понял твоего вопроса!
samakovajat879: написать программу питон а=[100,101,55,115,10] которая находит наименьшее число, которое больше 100
artum3d: ок
samakovajat879: большое спасибо если поможете
artum3d: Я помог поставь спасибо мне будет приятно
samakovajat879: хорошо

Ответы на вопрос

Ответил artum3d
1

a = [100, 101, 55, 115, 10] #Список

n = 100 # Больше 100

while True:

   b = min(a, key=lambda x:(x==0, x))

   if b < n: a.remove(b)

   else: break

b = min(a, key=lambda x:(x==0, x))

print(b)


artum3d: Надеюсь помог)
samakovajat879: большое спасибо
Новые вопросы