Прошу, помогите! Даю 100баллов!
Написать программу на языке Паскаль для решения следующей задачи:
Дано четырехзначное число, которое вводится с клавиатуры пользователем. Посчитать количество четных и нечетных цифр во введенном числе.
На проверку нужно прислать скриншоты окна программы с кодом и результатами работы. Входные данные задать самостоятельно.
Ответы на вопрос
Ответил tyngpuk
1
Ответ:
var a,c,n: integer;
begin
read(a);
if a mod 10 mod 2 = 0 then c:= c+1
else n:=n+1;
if a div 1000 mod 2 = 0 then c:= c+1
else n:=n+1;
if a div 10 mod 10 mod 2 = 0 then c:= c+1
else n:=n+1;
if a mod 1000 div 100 mod 2 = 0 then c:= c+1
else n:=n+1;
writeln(c,' ',n)
end.
Приложения:

slivaoliva:
Простите, а вы можете прислать еще скриншот работы? Я тогда вам поставлю "лучший" ответ и 5 звезд :)
Новые вопросы