ПРОШУ ПОМОЧЬ! ДАМ 100 БАЛЛОВ Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она: var x, y: real; begin readln(x, y); if y <= x then if y >= -x then if x*x+y*y <= 1 then write('принадлежит') else write('не принадлежит'); end.
Последовательно выполните следующее:
1)Приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу. 2)2) Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы).Приложения:

Ответы на вопрос
Ответил kage1998
0
Например при x=-1 y=0
Program gt;
var x,y:real;
begin
readln(x,y);
if(y<=x)and(y>=-x)and(x*x+y*y<=1)then writeln('YES') else
writeln('NO');
end.
Program gt;
var x,y:real;
begin
readln(x,y);
if(y<=x)and(y>=-x)and(x*x+y*y<=1)then writeln('YES') else
writeln('NO');
end.
Ответил Аноним
0
Нет, неправильно. Точка (0;1) принадлежит фигуре, а прога напишет, что не принадлежит, т.к. (y<=x) не выполняется.
Ответил kage1998
0
Program gt;
var x,y:real;
begin
readln(x,y);
if(x*x+y*y<=1)AND((y<=x)or(y>=-x))then writeln('YES') else
writeln('NO');
end.
var x,y:real;
begin
readln(x,y);
if(x*x+y*y<=1)AND((y<=x)or(y>=-x))then writeln('YES') else
writeln('NO');
end.
Ответил kage1998
0
прсото вместо and напиши or
Новые вопросы