Проходим цикл с предусловием. Нужно составить в Pascal 2 программы.
1) Дано натуральное число n. Написать программу для вычисления суммы членов последовательности 10,15,20...n
2) Вывести степени двойки от 1 до n.
Ответы на вопрос
Ответил Browze
0
1)
var a,n,sum:integer;
begin
read(n);
a:=10;
sum:=0;
while(a <> n)
begin
sum := sum + a;
a := a+5;
end;
end.
2)
var n:integer;
begin
read(n);
for var i := 1 to n do writeln(power(2,i));
end.
ПаскальАБС.Нет - версия Паскаля, нужен фраемфорк .нет в Паскале, если не работает - обнови паскаль
var a,n,sum:integer;
begin
read(n);
a:=10;
sum:=0;
while(a <> n)
begin
sum := sum + a;
a := a+5;
end;
end.
2)
var n:integer;
begin
read(n);
for var i := 1 to n do writeln(power(2,i));
end.
ПаскальАБС.Нет - версия Паскаля, нужен фраемфорк .нет в Паскале, если не работает - обнови паскаль
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад