Информатика, вопрос задал чайника , 8 лет назад

Программисты, помогите!!!! нужно написать программу на паскале дано натуральное число n. Найти произведение нечетных чисел от 1 до n. C Longint и integer.

Ответы на вопрос

Ответил MagicSpace
0
var
  n, i: integer;
  pr: longint;

begin
  readln(n);
  pr := 1;
  i := 1;
  while (i <= n) do begin
    i := i + 2;
    pr := pr * i;
  end;
  pr := pr div i;
  writeln(pr);
end.
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(1,ReadInteger,2).Aggregate(BigInteger(1),(p,q)->p*q))
end.
Приложения:
Новые вопросы