Информатика, вопрос задал leninisalive , 7 лет назад

ПРОГРАММИСТЫ ОТЗОВИТЕСЬ ПОЖАЛУЙСТА!!!
выпишите поэлементно содержимое массива а и определите значение переменной s после выполнения фрагмента программы:
var
a:array [1..5] of integer; i,s:integer;
begin
a[1]:=2;
for i:=2 to 4 do
a[i+1]:=i*a[i];
s:=a[2]+a[4];
writeln(s);
end.​

Ответы на вопрос

Ответил blemtoze
0

Ответ:

Задача, видимо, составлена некорректно, так как все значения в ней, кроме a[1] = 2, будут равны нулю.

Если в цикле for в условии изменить два на один, то тогда будет так:

а[1] = 2

а[2] = 2

а[3] = 4

а[4] = 12

a[5] = 48

s = 14

Новые вопросы