Программист на Северном полюсе работал за компьютером в варежках и поэтому мог набирать только 0 и 1, а клавиша 0 запала. Сможет ли он набрать число, состоящее только из единиц и при этом кратное заданному N? язык программирования любой
Входные данные
Программе дано число N (1 ≤ N ≤ 106).
Выходные данные
Вывести минимальное число, удволетворяющее требованию, или "NO" , если такого числа не существует.
Примеры
входные данные
100
выходные данные
NO
входные данные
57
выходные
Ответы на вопрос
Ответил MrMiner1
0
Язык: C++
_________________________
#include <iostream>
using namespace std;
int main(){
unsigned long long int a, b=0;
cin>>a;
if (a%2==0) {cout<<"NO"; return 0;}
for (unsigned long long int n=1; n<=1111111111111111111; n=n*10+1) {
if (n%a==0){cout<<n; return 0;}
++b;
}
cout<<"NO";
return 0;
}
_______________
Работает, если максимальная длина вводимой программистом последовательности из единиц равна 19. Предполагаю, что этого достаточно.
Ответил MrMiner1
0
Как до места доберусь, посмотрю
Ответил MrMiner1
0
#include < iostream >
using namespace std;
int main(){
unsigned long long int a, b=0;
cin>>a;
if (a%2==0) {cout<<"NO"; return 0;}
for (unsigned long long int n=1; n<=1111111111111111111; n=n*10+1) {
if (n%a==0){cout< ++b;
}
cout<<"NO";
return 0;
}
using namespace std;
int main(){
unsigned long long int a, b=0;
cin>>a;
if (a%2==0) {cout<<"NO"; return 0;}
for (unsigned long long int n=1; n<=1111111111111111111; n=n*10+1) {
if (n%a==0){cout< ++b;
}
cout<<"NO";
return 0;
}
Ответил MrMiner1
0
Вот набросал, теперь уже должно работать точно. Иначе длинная арифметика понадобится.
Ответил MrMiner1
0
#include
using namespace std;
int main(){
unsigned long long int a, b=0;
cin>>a;
if (a%2==0) {cout<<"NO"; return 0;}
for (unsigned long long int n=1; n<=1111111111111111111; n=n*10+1) {
if (n%a==0){cout << n; return 0;}
++b;
}
cout<<"NO";
return 0;
}
using namespace std;
int main(){
unsigned long long int a, b=0;
cin>>a;
if (a%2==0) {cout<<"NO"; return 0;}
for (unsigned long long int n=1; n<=1111111111111111111; n=n*10+1) {
if (n%a==0){cout << n; return 0;}
++b;
}
cout<<"NO";
return 0;
}
Ответил MrMiner1
0
Ну как сейчас?
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
География,
7 лет назад
Математика,
7 лет назад
Математика,
9 лет назад