Программирование.Язык Паскаль.
Помогите пожалуйста,нужно нарисовать блок схемы и написать программы
1)Дана строка и буква. Определить сколько слов в строке начинается на эту букву.Вывести эти слова.
2)Составить программу,которая в заданном слове с дефисом меняет местами части до и после дефиса
Ответы на вопрос
Ответил nosa2133
0
2 задача
var
s,a,b:string;
begin
writeln('Введите слово: '); readln(s);
b:=Copy(s,1,Pos('-',s)-1);
a:=Copy(s,Pos('-',s)+1,Length(s)-Length(b));
writeln(a,'-',b);
end.
var
s,a,b:string;
begin
writeln('Введите слово: '); readln(s);
b:=Copy(s,1,Pos('-',s)-1);
a:=Copy(s,Pos('-',s)+1,Length(s)-Length(b));
writeln(a,'-',b);
end.
Новые вопросы
Русский язык,
2 года назад
Алгебра,
2 года назад
Математика,
10 лет назад
Геометрия,
10 лет назад
География,
10 лет назад