Программирование в СИ++ !
Нужно написать программу, в которой 2 переменные типа float в main() являются локальными, а после используются в функции, которая вычисляет квадраты этих чисел.
Пожалуйста, исправьте мои ошибки.
#include <stdio.h>
#include <windows.h>
#include <iostream>
#include<cmath>
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
printf_s("Квадрат первого числа равен:%f\n", ch1);
printf_s("Квадрат второго числа равен:%f\n", ch2);
system("pause");
return(0);
}
int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
printf_s("Введите первое число:");
scanf_s("%f", &a);
printf_s("Введите второе число:");
scanf_s("%f", &b);
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
}
+ Напишите программу с возвратом значений
Ответы на вопрос
Ответил Аноним
1
Можно вот так, например (проверено в Dev C++):
#include <iostream>
#include <cmath>
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<<ch1<<endl;
cout<<"Квадрат второго числа равен:"<<ch2<<endl;
return(0);
}
int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";
cin>>a;
cout<<"Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}
#include <iostream>
#include <cmath>
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<<ch1<<endl;
cout<<"Квадрат второго числа равен:"<<ch2<<endl;
return(0);
}
int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";
cin>>a;
cout<<"Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}
AnnVoo:
Благодарю :)
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
7 лет назад