Информатика, вопрос задал Seletis , 7 лет назад

Программирование, python (хотя бы 2-3 задания)
1 Текстовый файл содержит только заглавные буквы латинского алфавита (ABC…Z). Определите символ, который чаще всего встречается в файле сразу после буквы A.
Например, в тексте ABCAABADDD после буквы A два раза стоит B, по одному разу — A и D. Для этого текста ответом будет B.
2 Текстовый файл содержит только заглавные буквы латинского алфавита (ABC…Z). Определите символ, который чаще всего встречается в файле после двух одинаковых символов.
Например, в тексте CCCBBABAABCC есть комбинации CCC, CCB, BBA и AAB. Чаще всего — 2 раза — после двух одинаковых символов стоит B, в ответе для этого случая надо написать B.
3 Текстовый файл содержит строки различной длины. Строки содержат только заглавные буквы латинского алфавита (ABC…Z). Определите количество строк, в которых буква E встречается чаще, чем буква A.
4. Текстовый файл состоит не более чем из символов X, Y, и Z. Определите максимальное количество идущих подряд символов, среди которых нет подстроки XZZY​

Ответы на вопрос

Ответил badnsnus
5

Ответ:

1)

from collections import Counter

f = open('НАЗВАНИЕ ФАЙЛА')

s = f.readline()

x = []

for i in range(len(s)-1):

   if s[i] == 'A':

       x.append(s[i+1])

print(Counter(x).most_common()[0][0])

2)

from collections import Counter

f = open('НАЗВАНИЕ ФАЙЛА')

s = f.readline()

x = []

for i in range(len(s)-2):

   if s[i] == s[i+1]:

       x.append(s[i+2])

print(Counter(x).most_common()[0][0])

3)

f = open('НАЗВАНИЕ ФАЙЛА')

s = f.readlines()

c = 0

for i in range(len(s)):

   if s[i].count('E') > s[i].count('A'):

       c += 1

print(c)

Новые вопросы