Информатика, вопрос задал Andrey12203 , 7 лет назад

Программирование (Питон)
Помогите пожалуйста, даю 75 баллов!
Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. (Питон)
Числа вводятся через input, а также, для последовательности, нужен цикл for

Ответы на вопрос

Ответил mirageKZ
3

Ответ:

Python

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

z=999999

for i in a:

   if z>i and i%2==0:

       z=i

if z!=999999:

   print('минимальное чётное число=', z)

else:

   print('Чётных чисел не найдено')

# 2 вариант с использованием sorted    

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

a=sorted(a)

for i in a:

   if i%2==0:

       print('минимальное чётное число=', i)

       break

   

Приложения:

Аноним: на дополнительные ходишь?) или школьная программа?)
Andrey12203: Канадская школьная программа
Аноним: круто) мы паскаль только проходили,да и то основы ток изучали)
Новые вопросы