Информатика, вопрос задал natalij37 , 2 года назад

Программирование на языке Puthon
Представь, что кадеты Марсакадемии играют в «лесенку»: первый подтянулся a раз. Второй на 1 раз больше. Первый снова на 1 раз больше, и так далее. В последний раз игрок сумел подтянуться b раз. Сколько всего подтягиваний было в игре?
Написать программу на языке puthon при помощи цикла while. Можно использовать if, else, >=, <=, ==, !=. желательно с обьяснениями #.....

Ответы на вопрос

Ответил mudrukartep43pz4
0

Ответ:

b = int(input("До скольки подтягиваний дошли : "))

c = 0

i = 1

while b > i:

   i += 1

   c += i

print(c + 1)

Объяснение:

Да не самое компактное, но...

Новые вопросы