Информатика, вопрос задал hfghjklLetKWaz , 9 лет назад

Программирование на языке Паскаль;

Напишите программу нахождения числа из трех, которое находится посередине.
Спасибо

Ответы на вопрос

Ответил srzontmp
0
var a,b,c,sr: real;
begin
  write('задайте a,b,c  ');  readln(a,b,c);
  sr:=a+b+c-max(a,max(b,c))-min(a,min(b,c));
  if a=sr then writeln('среднее а = ',a)
  else if b=sr then writeln('среднее b = ',b)
  else writeln('среднее c = ',c);
end.

Ответил srzontmp
0
Признаться, мне не доводилось встречаться с трансляторами, в которых нет встроенных функций max(a,b)  и min(a,b),  это наверно совсем какой-то убогий транслятор.
Ответил APALoff
0
TurboPascal может и убогий, но с него все начиналось. Но есть например FreePascal - который убогим уже не назовёшь - сейчас специально в нём проверил - выдал ошибку на MAX
Ответил srzontmp
0
А библиотека Math подключена?  Это минимальный набор стандартных функций. Или, может быть, тогда и для sin, cos, tg свои процедуры - функции писать?
Ответил APALoff
0
sin и cos как раз встроенные... а если уж нужно подключать библиотеку, то опять же - в коде этого не указано... потому и говорю - либо расписываешь функции сам (они маленькие) , либо уточнять версию требуемого компилятора.
Ответил srzontmp
0
Вопрос все равно будет удален, отмечен как нарушение, поэтому, чего копья ломать?
Новые вопросы