Информатика, вопрос задал Шоколадка525 , 2 года назад

Программирование на Python.

Звездный треугольник

Дано нечетное натуральное число nn. Напишите программу, которая печатает равнобедренный звездный треугольник с основанием, равным nn в соответствии с примером:

*
**
***
****
***
**
*

Формат входных данных
На вход программе подается одно нечетное натуральное число.

Формат выходных данных
Программа должна вывести треугольник в соответствии с условием.

Примечание. Используйте вложенный цикл for!



dkfcljytw: В примере кол-во звездочек сначала повышается на 1 каждую строку, потом так же спадает. Это обязательно?
Шоколадка525: да
timkafey: в данном примере nn чему равна?
timkafey: все
timkafey: понятно
dkfcljytw: Напомните, как округлить в большую сторону?
dkfcljytw: А если треугольник не в ту сторону?
dkfcljytw: Если не работает - убери "while 1:0" в конце
Шоколадка525: хорошо

Ответы на вопрос

Ответил dkfcljytw
2

Ответ:

======================

Объяснение:

Приложения:
Ответил timkafey
3

nn = int(input())

x = ''

for i in range(1, nn // 2 + 2):

   x = ''

   for z in  range(i): x += '*'

   print(x)

mas = [None] * (nn // 2)

m = 0

for i in range(0, nn // 2): mas[i] = '*' * (i + 1)

for i in range(0, len(mas)):

   m = len(mas) - i - 1

   print(mas[m])

можно было-бы сделать все в 3 строки, но чего-то нельзя в for сделать шаг в обратную сторону


dkfcljytw: И это странно
Шоколадка525: в обратную сторону? а не подойдет вот так: for I in range(3, 1, -1)
dkfcljytw: точно
Новые вопросы