Информатика, вопрос задал Шоколадка525 , 2 года назад

программирование на python
Сумма чисел
На вход программе подается последовательность целых чисел, каждое число на отдельной строке. Концом последовательности является любое отрицательное число. Напишите программу, которая выводит сумму всех членов данной последовательности.

Формат входных данных
На вход программе подается последовательность чисел, каждое число на отдельной строке.

Формат выходных данных
Программа должна вывести сумму членов данной последовательности.

Ответы на вопрос

Ответил mrpansar
10

num = int(input())

sm = 0

while num > -1:

   sm += num

   num = int(input())

print(sm)

Новые вопросы