Информатика, вопрос задал Шоколадка525 , 2 года назад

Программирование на Python
Количество пятерок
На вход программе подается последовательность целых чисел от 1 до 5, характеризующее оценку ученика, каждое число на отдельной строке. Концом последовательности является любое отрицательное число, либо число большее 5. Напишите программу, которая выводит количество пятерок.

Формат входных данных
На вход программе подается последовательность чисел, каждое число на отдельной строке.

Формат выходных данных
Программа должна вывести количество пятерок.

Ответы на вопрос

Ответил KnowsUser1
2

Ответ:

--- Python 3.8.3 ---

import typing

from typing import Callable

def ReadSeqWhile(SeqType, predicate: Callable[[int], bool]):

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   MarksList = ReadSeqWhile(int, lambda m: (m <= 5) and (m > 0) )

   fives = filter(lambda m: m == 5, MarksList)

   print(len(list(fives)))

   

if __name__ == "__main__":

   main()

Объяснение:

Новые вопросы