Программирование алгоритмов ветвления .Составить программу на Pascal
Приложения:

Ответы на вопрос
Ответил Санечка69
0
противный случай - это то же самое, что в другом случае или на языке информатики "иначе".
По-моему, в вашем случае "противного случая" нет, т. к. все возможные значения х учтены в первых случаях: число х может быть меньшим 0, большим 0, или равным 0. Но, если не придираться к условию, то программа выглядит так:
program funkciya;
var x, y: real;
begin
write('x='); readln(x);
if x<0 then y:=sin(sqr(x)) + 2*x
else if x>=0 then y:=sqrt(x)+sqrt(sqr(x)+1)
else y:=cos(x);
write('y=',y:5:2)
end.
По-моему, в вашем случае "противного случая" нет, т. к. все возможные значения х учтены в первых случаях: число х может быть меньшим 0, большим 0, или равным 0. Но, если не придираться к условию, то программа выглядит так:
program funkciya;
var x, y: real;
begin
write('x='); readln(x);
if x<0 then y:=sin(sqr(x)) + 2*x
else if x>=0 then y:=sqrt(x)+sqrt(sqr(x)+1)
else y:=cos(x);
write('y=',y:5:2)
end.
Новые вопросы
Алгебра,
2 года назад
Алгебра,
2 года назад
Геометрия,
8 лет назад
Математика,
8 лет назад
Биология,
9 лет назад
Математика,
9 лет назад