Программа в C++
Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.
Входные данные
Входная строка содержит единственное число – требуемое количество чисел N .
Выходные данные
Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.
Примеры
входные данные
5
выходные данные
2 4 6 8 10
Ответы на вопрос
Ответил clinteastwood2
0
#include <iostream>
using namespace std;
int main()
{
int n = 0;
cin >> n;
for (int i = 0; i < n * 2; i += 2) {
cout << i << endl;
}
return 0;
}
using namespace std;
int main()
{
int n = 0;
cin >> n;
for (int i = 0; i < n * 2; i += 2) {
cout << i << endl;
}
return 0;
}
Ответил skokov2001
0
Но ноль же не натуральное число
Ответил clinteastwood2
0
пруф: Some definitions, including the standard ISO 80000-2,[1] begin the natural numbers with 0, corresponding to the non-negative integers 0, 1, 2, 3, …, whereas others start with 1
Ответил skokov2001
0
А можете написать программу с учетом того,что ноль не натуральное число?
Ответил clinteastwood2
0
измените строку с int i = 0 на int i = 2
Ответил skokov2001
0
Спасибо огромное
Ответил karasikov
0
1 #include <cstdio>
2
3 int
4 main(void)
5 {
6 int n = 0;
7 scanf("%d", &n);
8 for (int i = 0, even_num = 2; i < n; i++, even_num += 2) {
9 printf("%d ", even_num);
10 }
11 return 0;
12 }
2
3 int
4 main(void)
5 {
6 int n = 0;
7 scanf("%d", &n);
8 for (int i = 0, even_num = 2; i < n; i++, even_num += 2) {
9 printf("%d ", even_num);
10 }
11 return 0;
12 }
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Алгебра,
8 лет назад
Алгебра,
8 лет назад
Химия,
9 лет назад