Информатика, вопрос задал CheaterVova777 , 7 лет назад

Программа python. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 9.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: количество чисел, оканчивающихся на 9.
Пример работы программы:
Входные данные
3
19
29
24
Выходные данные
2

Ответы на вопрос

Ответил vimmortal2
1

Программа:
Python:

N, count = int(input()), 0

for i in range(N):

   number = int(input())

   if number % 10 == 9:

       count += 1

print(count)

Объяснение:

В начале регистрируются переменные N, count. N - кол-во чисел в последовательности, которое вводится с клавиатуры; count - кол-во чисел, оканчивающихся на 9.

С помощью цикла for выполняем тело N раз. Вводится число с клавиатуры number и сразу же анализируется - если остаток деления на 10 равен 9, то count увеличивается на 1. При окончании цикла выводится значение count.

Результат:

3

19

27

10819

2

4

8375629

26672

123

94829

2

Новые вопросы