Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Программа определяет разность между максимальным и минимальным числом последовательности.
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: разность между максимальным и минимальным числом последовательности.
Входные данные
6
91
41
60
0
Выходные данные
85
Ответы на вопрос
Ответил defendercryak
1
Ответ:
program pr1;
const N=1000;
var a:array[1..n]of integer;
max,min,i:integer;
begin
for i:=1 to n do begin
read (a[i]);
if a[i]=0 then break;
end;
max:=-1;
min:=30001;
for i:=1 to n do begin
if a[i]>max then max:=a[i];
if (a[i]<min) and (a[i]>0) then min:=a[i];
end;
write(max-min);
end.
gagaytu:
Ммм спасибо сладкий
Новые вопросы